SharePoint 2016: UserProfileApplicationProxy Proxy is null

Posted by

Hi all!

After a looong time without installing a new SharePoint farm, yesterday it was the day 🙂 I needed to install a new farm, so I started doing it and it was everything so simple. After I installed the farm I was reveiwing the Event Viewer in order to see any errors, and I realize that the farm was throwing a lot of errors complaining about “UserProfileApplicationProxy Proxy is null”

The error itself, makes sense since I did not provisioned the User Profile Service Application, so what can I do? Disable the timers of course 🙂

  1. Log in to Central Administration
  2. Click the Monitoring link on the left and then under Timer Jobs click Review job definitions
  3. On the left click Job History
  4. Change the View from All to Failed Jobs
  5. Click the link for the failed job – in my case I am disabling the following jobs:- UserProfileApplicationProxy – Per Database User Profile to SharePoint Full Synchronization
    – UserProfileApplicationProxy – Unified Group Processing High Performance Job
  6. Click Disable

And that’s all, problem solved and not more errors in the event viewer. To the next thing!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s